Commit 39eb59e3 authored by David Woodhouse's avatar David Woodhouse

Require GnuTLS 3.2.10+ for GnuTLS builds

It's not worth the effort to keep it building for <3.2 any more; nobody
cares... or noticess when we accidentally break it. So kill it; we've
been threatening to for ages.

Use 3.2.10 as the base because 3.2.x before that was broken on Windows.
Signed-off-by: default avatarDavid Woodhouse <>
parent d298a8b6
......@@ -279,18 +279,9 @@ fi
# First, check if GnuTLS exists and is usable
if test "$with_gnutls" = "yes" || test "$with_gnutls" = ""; then
PKG_CHECK_MODULES(GNUTLS, gnutls >= 2.12.16,
[if ! $PKG_CONFIG --atleast-version=2.12.16 gnutls; then
AC_MSG_WARN([Your GnuTLS is too old. At least v2.12.16 is required])
elif test "$have_win" = "yes"; then
AC_MSG_CHECKING([for broken GnuTLS Windows versions])
if $PKG_CONFIG --atleast-version=3.2.0 gnutls &&
! $PKG_CONFIG --atleast-version=3.2.10 gnutls; then
[if ! $PKG_CONFIG --atleast-version=3.2.10 gnutls; then
AC_MSG_WARN([Your GnuTLS is too old. At least v3.2.10 is required])
fi], [:])
......@@ -23,7 +23,7 @@ libraries and tools installed:</p>
<li>Either <b><tt>OpenSSL</tt></b> or <b><tt>GnuTLS</tt></b></li>
<li>Either <b><tt>OpenSSL</tt></b> or <b><tt>GnuTLS</tt></b> <i>(v3.2.10+)</i></li>
And <em>optionally</em> also:
......@@ -15,6 +15,7 @@
<li><b>OpenConnect HEAD</b>
<li>Drop support for GnuTLS older than 3.2.10.</li>
<li>Fix <tt>--passwd-on-stdin</tt> for Windows to not forcibly open console.</li>
<li>Fix portability of shell scripts in test suite.</li>
<li>Add Google Authenticator TOTP support for Juniper.</li>
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment