Commit e4d2e931 authored by Giulio Benetti's avatar Giulio Benetti

Bug 1606119 - Fix PPC HW Crypto build failure r=jcj

All Altivec *_be() functions are supported from gcc version 8.x not 5.x
so modify gcc version check that at the moment cause build failure due
to missing Altivec *_be() functions.

--HG--
extra : amend_source : 217aa37aba9f07e4fd72e8dfd7a9fa49b31fca93
parent c3e84d83
......@@ -41,11 +41,11 @@
#endif
/*
* PPC CRYPTO requires at least gcc 5 or clang. The LE check is purely
* PPC CRYPTO requires at least gcc 8 or clang. The LE check is purely
* because it's only been tested on LE. If you're interested in BE,
* please send a patch.
*/
#if (defined(__clang__) || (defined(__GNUC__) && __GNUC__ >= 5)) && \
#if (defined(__clang__) || (defined(__GNUC__) && __GNUC__ >= 8)) && \
defined(IS_LITTLE_ENDIAN)
#define USE_PPC_CRYPTO
#endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment