Commit 6643e941 authored by Nicolas Dufresne's avatar Nicolas Dufresne

meson: Add a qt5 feature

This allow opting out items of the builds the depends on QT5 library.
Auto-detection of QT5 in cross-build requires host tools to match with the
sysroot, and detection of mis-match is not fully reliable.

Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/817>
parent 3cb7540c
......@@ -79,6 +79,7 @@ option('glib-asserts', type : 'feature', value : 'enabled', yield : true,
description: 'Enable GLib assertion (auto = enabled for development, disabled for stable releases)')
option('glib-checks', type : 'feature', value : 'enabled', yield : true,
description: 'Enable GLib checks such as API guards (auto = enabled for development, disabled for stable releases)')
option('qt5', type : 'feature', value : 'auto', yield : true, description : 'Qt5 QML examples')
# Common options
option('package-name', type : 'string', yield : true,
......
if get_option('qt5').disabled()
subdir_done()
endif
qt5_mod = import('qt5')
qt5gui_dep = dependency('qt5', modules : ['Core', 'Gui', 'Widgets'], required : false)
......
if get_option('qt5').disabled()
subdir_done()
endif
if x11_dep.found()
if gtk_x11_dep.found()
executable('gtk-videooverlay', 'gtk-videooverlay.c',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment