Commit 06a379d4 authored by spiiroin's avatar spiiroin

[packaging] Adjust libsystemd build requirements

The systemd development packages have changed and there are build time
warnings like:

  sd_notify was moved to libsystemd. Do not use libsystemd-daemon.

Use libsystemd as instructed.
Signed-off-by: spiiroin's avatarSimo Piiroinen <simo.piiroinen@jollamobile.com>
parent f1a17e3c
......@@ -75,7 +75,7 @@ AM_CONDITIONAL([CONNMAN], [test x$connman = xtrue])
AC_ARG_ENABLE([systemd], AS_HELP_STRING([--enable-systemd], [Enable systemd notify interface @<:@default=false@:>@]),
[case "${enableval}" in
yes) systemd=true ; CFLAGS="-DSYSTEMD -lsystemd-daemon $CFLAGS" ;;
yes) systemd=true ; CFLAGS="-DSYSTEMD $CFLAGS" ;;
no) systemd=false ;;
*) AC_MSG_ERROR([bad value ${enableval} for --enable-systemd]) ;;
esac],[systemd=false])
......@@ -98,6 +98,7 @@ PKG_CHECK_MODULES([USB_MODED], [
libudev
libkmod
ssu-sysinfo
libsystemd
])
AC_SUBST(USB_MODED_LIBS)
......
......@@ -14,7 +14,7 @@ BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(udev)
BuildRequires: pkgconfig(libkmod)
BuildRequires: doxygen
BuildRequires: pkgconfig(libsystemd-daemon)
BuildRequires: pkgconfig(libsystemd)
BuildRequires: pkgconfig(ssu-sysinfo)
Requires: lsof
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment