Commit 8be24c18 authored by Vesa Halttunen's avatar Vesa Halttunen

Install the .prf to the correct location on Qt5

parent 3ae3aca6
......@@ -38,7 +38,8 @@ HEADERS += \
SOURCES += \
transferengineinterface.cpp
OTHER_FILES += nemotransfernegine.pc nemotransferengine-plugin.prf
equals(QT_MAJOR_VERSION, 4): OTHER_FILES += nemotransfernegine.pc nemotransferengine-plugin.prf
equals(QT_MAJOR_VERSION, 5): OTHER_FILES += nemotransfernegine-qt5.pc nemotransferengine-plugin-qt5.prf
headers.files = $$HEADERS
equals(QT_MAJOR_VERSION, 4): headers.path = /usr/include/TransferEngine
......@@ -51,7 +52,8 @@ equals(QT_MAJOR_VERSION, 4): pkgconfigpc.files = nemotransferengine.pc
equals(QT_MAJOR_VERSION, 5): pkgconfigpc.files = nemotransferengine-qt5.pc
prf.path = $$[QT_INSTALL_DATA]/mkspecs/features
prf.files = nemotransferengine-plugin.prf
equals(QT_MAJOR_VERSION, 4): prf.files = nemotransferengine-plugin.prf
equals(QT_MAJOR_VERSION, 5): prf.files = nemotransferengine-plugin-qt5.prf
INSTALLS += target headers prf pkgconfigpc
###################################################################
# transferengine plugin feature
###################################################################
!contains(DEFINES, BUILD_LIBTRANSFERENGINE) {
CONFIG += qt plugin
QT += network
LIBTRANSFERENGINE_INC_DIR = /usr/include/TransferEngine-qt5
INCLUDEPATH += $${LIBTRANSFERENGINE_INC_DIR}
DEPENDPATH += $${LIBTRANSFERENGINE_INC_DIR}
# We need to include these for MOC.
HEADERS += $${INCLUDEPATH}/transferplugininterface.h
HEADERS += $${INCLUDEPATH}/mediatransferinterface.h
LIBTRANSFERENGINE_LIB_DIR = /usr/lib
unix: QMAKE_FLAGS += $${QMAKE_LFLAGS_RPATH}$${LIBTRANSFERENGINE_LIB_DIR}
LIBS += -L$${LIBTRANSFERENGINE_LIB_DIR}
qtAddLibrary(nemotransferengine-qt5)
}
......@@ -43,7 +43,7 @@ Requires: nemo-transferengine = %{version}
%files devel
%defattr(-,root,root,-)
%{_includedir}/TransferEngine-qt5/*.h
%{_datadir}/qt5/mkspecs/features/nemotransferengine-plugin.prf
%{_datadir}/qt5/mkspecs/features/nemotransferengine-plugin-qt5.prf
%{_libdir}/pkgconfig/nemotransferengine-qt5.pc
%package ts-devel
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment