Commit b9de1d27 authored by Slava Monich's avatar Slava Monich

[mms-settings] Changed dconf path for MMS settings

Previously, MMS settings were stored right in the IMSI directory at the
root of the dconf namespace. They have been moved to /imsi/ folder and
MMS settings now live in the mms subfolder, i.e. /IMSI/ -> /imsi/IMSI/mms/

Old settings are migrated to the new location the first time they are
requested. Instead of GSettings we now directly use DConf because it
appears to be impossible to properly implement migration with GSettings.
That makes gschema obsolete but we need to keep it around for backward
compatibility reasons.
parent 60517c33
......@@ -17,7 +17,7 @@ include ../mms-lib/Config.mak
PKGS = gio-unix-2.0 gio-2.0
LIB_PKGS = libwspcodec libsoup-2.4 $(RESIZE_PKG) $(PKGS)
LIB_PKGS = libwspcodec libsoup-2.4 dconf $(RESIZE_PKG) $(PKGS)
# Default target
CONFIG += link_pkgconfig
PKGCONFIG += gio-unix-2.0 gio-2.0 glib-2.0 libsoup-2.4 libwspcodec ImageMagick
PKGCONFIG += gio-unix-2.0 gio-2.0 glib-2.0 libsoup-2.4 dconf libwspcodec ImageMagick
MMS_LIB_DIR = $$_PRO_FILE_PWD_/../mms-lib
MMS_OFONO_DIR = $$_PRO_FILE_PWD_/../mms-ofono
......@@ -3,7 +3,7 @@
.PHONY: clean all debug release
# Required packages
PKGS = gio-2.0
PKGS = dconf
# Default target
......@@ -2,7 +2,7 @@ TEMPLATE = lib
CONFIG += staticlib
CONFIG -= qt
CONFIG += link_pkgconfig
PKGCONFIG += glib-2.0 gio-2.0 gio-unix-2.0
PKGCONFIG += glib-2.0 dconf
INCLUDEPATH += include
INCLUDEPATH += ../mms-lib/include
QMAKE_CFLAGS += -Wno-unused
<?xml version="1.0" encoding="UTF-8"?>
Path is /IMSI/
Path is /imsi/IMSI/mms/
These defaults should match those defined in mms_settings.h
<schema id="org.nemomobile.mms.sim">
This diff is collapsed.
......@@ -12,9 +12,10 @@ Requires: ofono
BuildRequires: python
BuildRequires: file-devel
BuildRequires: libpng-devel
BuildRequires: libexif-devel
BuildRequires: libjpeg-turbo-devel
BuildRequires: pkgconfig(dconf)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(libexif)
BuildRequires: pkgconfig(glib-2.0) >= 2.32
BuildRequires: pkgconfig(libsoup-2.4) >= 2.38
BuildRequires: pkgconfig(libwspcodec) >= 2.2
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment