Commit 439ea03a authored by John Brooks's avatar John Brooks

[mms-engine] Avoid using qmake to detect Qt version

qtchooser systems will only have a default choice for qmake when a
default package is installed, which we can't depend on.

There is no reason to keep Qt4 support here.
parent ec40b182
......@@ -13,11 +13,7 @@ RESIZE_DEFINES = -DMMS_RESIZE_IMAGEMAGICK
RESIZE_CFLAGS = $(shell pkg-config --cflags $(RESIZE_PKG))
else
ifeq ($(MMS_RESIZE),Qt)
ifeq ($(shell qmake --version | grep "Using Qt version 5"),)
RESIZE_PKG = QtGui
else
RESIZE_PKG = Qt5Gui
endif
RESIZE_PKG = Qt5Gui
RESIZE_LIBS = -lstdc++
RESIZE_DEFINES = -DMMS_RESIZE_QT
RESIZE_CPPFLAGS = $(shell pkg-config --cflags $(RESIZE_PKG))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment