Commit f5df3b93 authored by Niels Breet's avatar Niels Breet

[security] Upgrade eglibc to 2.19-0ubuntu6.13. Fixes MER#1633

Fixes CVE-2017-1000366, CVE-2015-8982, CVE-2015-8983, CVE-2015-8984,
CVE-2016-1234, CVE-2016-3706, CVE-2016-4429, CVE-2016-6323, CVE-2015-1781,
CVE-2014-8121, CVE-2014-9761, CVE-2015-5277, CVE-2015-8776, CVE-2015-8777,
CVE-2015-8778, CVE-2015-8779, CVE-2016-3075, CVE-2016-2856, CVE-2013-2207.
parent f55813bb
* Thu Jun 29 2017 Niels Breet <niels.breet@jolla.com> - 2.19+6.13
- Upgrade to eglibc_2.19-0ubuntu6.13
- Fixes CVE-2017-1000366, CVE-2015-8982, CVE-2015-8983, CVE-2015-8984,
CVE-2016-1234, CVE-2016-3706, CVE-2016-4429, CVE-2016-6323, CVE-2015-1781,
CVE-2014-8121, CVE-2014-9761, CVE-2015-5277, CVE-2015-8776, CVE-2015-8777,
CVE-2015-8778, CVE-2015-8779, CVE-2016-3075, CVE-2016-2856, CVE-2013-2207.
MER#1633
* Sun Aug 28 2016 Pasi Sjöholm <pasi.sjoholm@siirappi.com> - 2.19+6.9 * Sun Aug 28 2016 Pasi Sjöholm <pasi.sjoholm@siirappi.com> - 2.19+6.9
- Upgrade to eglibc_2.19-0ubuntu6.9 and apply Debian/Ubuntu patches - Upgrade to eglibc_2.19-0ubuntu6.9 and apply Debian/Ubuntu patches
before Mer specific ones. before Mer specific ones.
......
...@@ -8,7 +8,7 @@ ...@@ -8,7 +8,7 @@
Summary: Embedded GLIBC (EGLIBC) is a variant of the GNU C Library (GLIBC) Summary: Embedded GLIBC (EGLIBC) is a variant of the GNU C Library (GLIBC)
Name: glibc Name: glibc
Version: 2.19+6.9 Version: 2.19+6.13
Release: 1 Release: 1
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries. # GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
...@@ -20,7 +20,7 @@ License: LGPLv2+ and LGPLv2+ with exceptions and GPLv2+ ...@@ -20,7 +20,7 @@ License: LGPLv2+ and LGPLv2+ with exceptions and GPLv2+
Group: System/Libraries Group: System/Libraries
URL: http://www.eglibc.org/ URL: http://www.eglibc.org/
Source0: https://launchpad.net/ubuntu/+archive/primary/+files/eglibc_2.19.orig.tar.xz Source0: https://launchpad.net/ubuntu/+archive/primary/+files/eglibc_2.19.orig.tar.xz
Source1: http://archive.ubuntu.com/ubuntu/pool/main/e/eglibc/eglibc_2.19-0ubuntu6.9.debian.tar.xz Source1: http://archive.ubuntu.com/ubuntu/pool/main/e/eglibc/eglibc_2.19-0ubuntu6.13.debian.tar.xz
Source11: build-locale-archive.c Source11: build-locale-archive.c
# glibc-arm-alignment-fix.patch: safe but probably not needed anymore # glibc-arm-alignment-fix.patch: safe but probably not needed anymore
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment