Commit 3f323cb3 authored by Jussi Laakkonen's avatar Jussi Laakkonen

[connman] Require iptables 1.6.1+git2. Contributes to JB#44205

Set connman to require iptables 1.6.1+git2 as it contains the fix for
simultaneous use of IPv4 and IPv6 iptables rules with matches that have
different functionalities for the address families.

Also a bit of cleanup for firewall.c.
parent 94b106f5
......@@ -1251,7 +1251,7 @@ static bool is_string_digits(const char *str)
}
/* Protocols that iptables supports with -p or --protocol switch */
const char *supported_protocols[] = { "tcp",
static const char *supported_protocols[] = { "tcp",
"udp",
"udplite",
"icmp",
......@@ -1264,7 +1264,7 @@ static bool is_string_digits(const char *str)
"dccp",
"all",
NULL
};
};
static bool is_supported(int type, enum iptables_switch_type switch_type,
const char* group, const char *str)
......
......@@ -13,8 +13,8 @@ Requires: ofono
Requires: pacrunner
Requires: connman-configs
Requires: systemd
Requires: iptables >= 1.6.1
Requires: iptables-ipv6 >= 1.6.1
Requires: iptables >= 1.6.1+git2
Requires: iptables-ipv6 >= 1.6.1+git2
Requires: libgofono >= 2.0.0
Requires: libglibutil >= 1.0.21
Requires: libdbusaccess >= 1.0.2
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment